User talk:Miked0801

From RoboWiki
(Difference between revisions)
Jump to: navigation, search
(Javax.Swing issue with FloodGrapher stuff.)
(Swing isn't deprecated)
Line 58: Line 58:
 
----
 
----
 
Does Kawigi's old floodGrapher stuff still work with the latest versions of Java for anyone else?  I get tons of Javax.Swing exceptions when I try to view a graph.  It looks like swing has be deprecrated.  Is this so?
 
Does Kawigi's old floodGrapher stuff still work with the latest versions of Java for anyone else?  I get tons of Javax.Swing exceptions when I try to view a graph.  It looks like swing has be deprecrated.  Is this so?
 +
: I've never tried FloodGrapher, but I'm almost certain swing is not deprecated, even in Java 7 beta versions, but may something changed that requires old code to work properly. --[[User:Zyx|zyx]] 02:05, 9 June 2009 (UTC)

Revision as of 02:05, 9 June 2009

Hey! Do you have to remove the "Inactive Authors" category now? =) --Voidious 17:31, 28 April 2009 (UTC)

Lol - I think I already did. Gotta upload an Infinty page now that I fixed a minor bug with him.

Hey man, I happened to randomly notice that an old version of BrokenSword is appearing in the melee rumble. Did you point your client at the new RoboRumble/Participants/Melee page? Actually I don't know how that would happen anyway, unless it uses the last participants list it saw if it can't find the list. Or maybe you just had some cached / unuploaded results from the last time you ran it? --Voidious 20:06, 28 April 2009 (UTC)

Good call. Just fixed that. Sorry for the out of date files being added. I'm running the new link now. Someone's going to have to clean up my mess on that one. --Miked0801


Just to let you know, I've noticed you signing with --[[User:Miked0801|Miked0801]] or --[[User:Miked0801]]. Just to let you know, on the new wiki you can simply sign with --~~~~ (or the signature button if you have js enabled), and it'll automatically turn it to a complete signature including timestamp even. Just a tip :) --Rednaxela 17:01, 29 April 2009 (UTC)

Yep, someone else let me know that too. :) --Miked0801 20:36, 29 April 2009 (UTC)

Oh hey, speaking of code shrinking, I just thought I'd point out the new "Rules" class if you hadn't seen it. I resisted using it for the longest time to ensure compatibility with old Robocodes, but it's been in there for a while and we now have a way of filtering out old clients anyway. So now I'm compiling with Jikes and Robocode 1.4.9, so I can use Rules but still compile with Jikes. --Voidious 14:21, 7 May 2009 (UTC)

Alright, what is this rules class you speak of? --Miked0801 17:54, 7 May 2009 (UTC)

The robocode.Rules class can be used to calculate the max turn rate, bullet power, bullet damage and so on. It is the one use by game engine, and it is now public. » Nat | Talk » 18:12, 7 May 2009 (UTC)

(edit conflict) It's a utilities class that provides methods for a bunch of basic stuff, like bullet speed, damage, turn rate, etc. Rules class in Robocode API. It's definitely an unfair advantage over legacy bots, but that's your decision to grapple with. =) --Voidious 18:16, 7 May 2009 (UTC)

I checked it out and none of its functions would have use in DustBunny nor Infinity, though bullet speed would become useful for linear leading if I stored my firepower instead of just calculating in place. --Miked0801 20:33, 7 May 2009 (UTC)


Your client seems to be uploading 1-on-1 results for retired bots? stelo.PastFuture 1.0, for example. This is easy to fix but if there is a bigger problem going on... --Darkcanuck 03:55, 8 May 2009 (UTC)

Perhaps I've got the wrong page pointed at (again) for rumble. I'll check when I get home. --Miked0801 20:27, 8 May 2009 (UTC)


Hi, it's good to see a 'veteran' coming back and working on nanos. :D I have been on rest since the beginning of April, but now I think I should do something to get back the top 3 rank. ;) --HUNRobar 16:02, 13 May 2009 (UTC)

First Place in Melee and 1v1 are sooo close. I got back into this again because I've got some late night hours free with a newborn - just like last time I got into the fun. Come on, just 1% in each. There's gotta be something I can tweak to get that right?  :) --Miked0801 18:49, 13 May 2009 (UTC)

Just watch out because I'm going to make an update on my top bots. :) See Pugio 1.3 for example. ;) --HUNRobar 19:13, 13 May 2009 (UTC)

Wow, nice update. Game on! --Miked0801 20:28, 13 May 2009 (UTC)

Are we allowed to use: Vector<Double> vect = new Vector<Double>();

type things and set the "-source 1.5" flag for our bots? If so, that will save some codesize for me.

Yep, Robocode has required Java 5 for a while now, so that should be fine. I use generics in Diamond and it definitely ran fine in my 1.5.4 RoboRumble clients, which is the oldest version allowed for the rumble. So that saves code size, eh? Hmm, thanks for the info... =) --Voidious 01:12, 27 May 2009 (UTC)

Oh yeah, but I forgot, Jikes only supports Java 1.4, that's why I never used generics in my MiniBots. But I'll definitely compare it to normal javac with generics now that I know this. --Voidious 01:15, 27 May 2009 (UTC)
Sorry for triple post, but what makes you say it will save you code size? I tried changing Komarious to use generics for its one collection, and it had no effect on code size. --Voidious 01:23, 27 May 2009 (UTC)
Lol, I just realized I never ran codesize on my micro with generics in place. Doh! Well, generics look cleaner if anything else :) --Miked0801 02:25, 27 May 2009 (UTC)
Generic only available in source, it will ease out at compile time and every casting will come back (try decompile the generic-ize class and see) The generic only to check the type sefty. This is from java specification. And because the codesize library check the byte code, not the not the source code so this has no effect. And this is not require Java 5 to run since it isn't in the byte code, ad long as you only use the classes from the target version.

While scanning my local harddrive, I found a newer version of Radnor.DoctorBob (1.50). Any objections to me entering this into the fray and seeing how well it does in tandem with 1.42?

And removed. Failed experiment there.

Does Kawigi's old floodGrapher stuff still work with the latest versions of Java for anyone else? I get tons of Javax.Swing exceptions when I try to view a graph. It looks like swing has be deprecrated. Is this so?

I've never tried FloodGrapher, but I'm almost certain swing is not deprecated, even in Java 7 beta versions, but may something changed that requires old code to work properly. --zyx 02:05, 9 June 2009 (UTC)
Personal tools