Melee client corrupted

From RoboWiki
Jump to: navigation, search

Hello

I think one of your meleerumble clients is corrupted, since it is continuously re-running battles against old versions of Neuromancer and Firestarter. Normally a client should get new bots once every 2 hours, but it has been a few days since the Firestarter update and yours is still running the old versions. Could you investigate?

Thanks

Skilgannon (talk)09:49, 31 October 2017

Weird. The client was running battles with new version of bots but also attempted to upload ratings for the old ones. I cleared caches (files) and temporary (temp) dirs. Strangely enough I see the following at start up

Iteration number 0
Could not load properties file: ./roborumble/files/codesizemelee.txt
Downloading rating files ...
Downloading participants list ...
Downloading missing bots ...
Downloaded cb.fire.Firestarter 2.0d into ./robots/cb.fire.Firestarter_2.0d.jar
Removing old participants from server ...
Removing entry ... cb.fire.Firestarter_2.0e from meleerumble
OK. cb.fire.Firestarter 2.0e retired from meleerumble
Removing entry ... eem.EvBotNG_v11.0 from meleerumble
OK. eem.EvBotNG v11.0 retired from meleerumble

Note that eem.EvBotNG v11.0 is 3 version behind, cb.fire.Firestarter_2.0e is one version behind.

I cannot figure out where does it read these versions since I cleared caches. My only assumption it is coming from the literumble. Am I right?

Nevertheless, despite the reported removal at the end of the battle I see

Fighting battle 0 ... fire219.CatBot 1.0,stelo.Spread 0.3,gh.mini.Gruwel 0.9,ara.Shera 0.88,wee.Gem 1.8.4,davidalves.net.DuelistNanoMelee 1.01,pedersen.Moron 2.0,zyx.mega.YersiniaPestis 3.1,emp.Yngwie 1.11,zyx.nano.BacillusComma 1.0
RESULT = stelo.Spread 0.3 wins, gh.mini.Gruwel 0.9 is second.
Fighting battle 1 ... pedersen.Ugluk 1.1.1,florent.XSeries.X2 0.12,gimp.GimpBot 0.1,yk.JahRoslav 1.1,agrach.Dalek 1.0,lrem.Spectre 0.4.4,jcs.Seth 1.8,maribo.FollowFire 1,DTF.Kludgy 1.2b,franzor.Lizt 1.3.1
RESULT = pedersen.Ugluk 1.1.1 wins, DTF.Kludgy 1.2b is second.
Fighting battle 2 ... stelo.WangRobot 1.0,dsw.StaticD 1.0,kurios.DOSexe .9b,jk.melee.Neuromancer 6.9,amk.Punbot.Punbot 0.01,oog.melee.CapuletDroid 1.1,lessonz.robocode.Oz 0.5.0,cs.sheldor.Talon 1.1,eem.IWillFireNoBullet v2.8,aaa.ScaledBot 0.01d
RESULT = jk.melee.Neuromancer 6.9 wins, aaa.ScaledBot 0.01d is second.
...
...
Ignoring: cb.fire.Firestarter 2.0e,cb.fire.Firestarter 2.0d,SERVER
Ignoring: amk.Punbot.Punbot 0.01,cb.fire.Firestarter 2.0e,SERVER

Note that Firestarter was not even fighting the battles. Where is it coming from?

It all might be related to the sometimes observed appearance of two versions of the same bot in the rumble ratings which lingers for several hours.

Beaming (talk)14:15, 31 October 2017

Interesting, maybe it isn't your client uploading these bots then. Maybe it is User:Rsalesc? I should really add some more logging to the rumble so this kind of thing is more obvious.

Skilgannon (talk)16:12, 31 October 2017

Oh, ok. Just noticed I left the rumble client open in my university labs (rsalesc_dahia), and its connection is a bit sketchy. That explains a lot. I'll be there soon to shut it down.

Rsalesc (talk)16:24, 31 October 2017
 
 
 
Personal tools