Remove bots with underscores in version numbers?

Jump to navigation Jump to search

How did you even get an underscore in the version field?

The robot packager says "Please enter a version number for this robot (up to 10 word chars: letters, digits, dots, but no spaces)", and greys out the "Next" button if you type an underscore.

MultiplyByZer0 (talk)20:36, 27 August 2017

I never tried package my bot with robocode ;) I use a utility which transpiles my bot to Java 6 (I'm using Java 8 and it's features) and package it at the same time.

Xor (talk)03:48, 28 August 2017

> I use a utility which transpiles my bot to Java 6

You can just compile with:

javac -target 1.5 -source 1.5 [...]
MultiplyByZer0 (talk)04:09, 28 August 2017

This won't work as I'm using Java 8 features, etc. default methods, which can only be transpiled with some tricks.

Xor (talk)04:15, 28 August 2017