Upgrade client version

From RoboWiki
Jump to: navigation, search

Codesize 1.2 for Java 7, 8, 9 (Experimental) is ready.

Do we need to fix other stuff for RoboRumble before I make another release?

Fnl (talk)19:42, 28 October 2018

You do not have permission to edit this page, for the following reason:

The action you have requested is limited to users in the group: Users.


You can view and copy the source of this page:

Return to Thread:Talk:RoboRumble/Upgrade client version/reply (31).

 

The melee pairing fix is now fully tested and available as a pull request:

https://github.com/robo-code/robocode/pull/13

discussions:

http://robowiki.net/wiki/Thread:Talk:RoboRumble/Upgrade_client_version/reply_(2)

Xor (talk)04:22, 4 November 2018

Your pull request has now been merged and I have assembled and put a beta version here: https://robocode.sourceforge.io/files/robocode-1.9.3.4-Beta-setup.jar

If you are satisfied with this version, I will make the release. :-)

Fnl (talk)22:03, 6 November 2018

Thanks, I will test it.

Xor (talk)06:11, 7 November 2018
 

It seems that the codesize part is not working completely. Both in roborumble and in the builtin editor. info: I'm using Oracle JDK 1.8.0_181 on mac.

Xor (talk)06:25, 7 November 2018
 

It seems that codesize-1.2.jar cannot work on my machine at all. Can you have a test of this version as well?

Xor (talk)08:51, 7 November 2018
 
 
 
Personal tools