Talk:Robocode/Download And Install

From Robowiki
Jump to navigation Jump to search

Downloading Issues

I'm trying to download version 1.7.2, but its not working for me. I downloaded the robocode-, but when I try to open it I just get an error message that I can't read. Does anyone know how I can get robocode on my computer again?--CrazyBassoonist 15:43, 8 June 2010 (UTC)

I just downloaded and installed it without problems on my Mac from this page. Have you tried re-downloading? Or maybe you could try grabbing an older version from here to see if that works? --Voidious 15:33, 10 June 2010 (UTC)

I've tried it many times, and every file I download gives me an error message when I run it--CrazyBassoonist 14:32, 21 June 2010 (UTC)

Argh, really? I haven't tried with the latest versions, but you used to be able to manually extract the .jar and just copy the directory over. A .jar is the same format as a .zip, so just rename it to .zip/double click, or open it with an unzip program. Maybe that would work? --Voidious 00:09, 22 June 2010 (UTC)

Well, I got a new computer (this time with Windows 7, if that makes a difference) and tried downloading Robocode again. When I ran Robocode this time it didn't work, so I tried using the "troubleshoot compatibility" feature and got the message "The specified path does not contain a valid program. Please select a valid program (ending in .exe)." The file already in the blank says "C:\robocode\robocode.bat" and when I looked for a file ending in .exe I couldn't find one. Does anyone know how to get it to work? Thanks--CrazyBassoonist 13:47, 8 August 2010 (UTC)

Are you able to run Robocode by double-clicking the C:\robocode\robocode.bat" directly? --Nat Pavasant 13:51, 8 August 2010 (UTC)

No, the same thing happens and I get the same message about it not having a valid program--CrazyBassoonist 13:53, 8 August 2010 (UTC)

Could you provide me a screen capture? --Nat Pavasant 13:59, 8 August 2010 (UTC)

Of what happens when I open the program? I get a screen that opens really fast and then closes and nothing happens, so I would have trouble getting a screen shot. I can provide you with a picture of the troubleshooting message if you want though--CrazyBassoonist 14:02, 8 August 2010 (UTC)

Well, I've found that I can open Robocode by opening the robocode.jar file in the libs folder, but there aren't any sample robots on it, the compiler won't work, and I can't import robots. So that hasn't helped me much.--CrazyBassoonist 14:33, 8 August 2010 (UTC)

Are you sure you have Java installed properly? --Nat Pavasant 14:41, 8 August 2010 (UTC)

I just managed to take a very fast screenshot, I'll try to upload that--CrazyBassoonist 14:52, 8 August 2010 (UTC) Robocode Problem.png Here it is. Anyone know what this means I should do?--CrazyBassoonist 14:57, 8 August 2010 (UTC)

Oh, it looks like you either don't have Java installed, or you don't have it on the PATH. I'd try grabbing the Java SDK from Sun here and installing it, then trying again. --Voidious 15:05, 8 August 2010 (UTC)

Well, I remember Downloading Java and I've been able to run programs that use Java, but I'll try downloading it again.--CrazyBassoonist 15:09, 8 August 2010 (UTC)

Its still not working. How do I change the PATH?--CrazyBassoonist 15:11, 8 August 2010 (UTC)

Start > Control Panel > System > Advanced system settings > Environments Variables > Choose PATH in System variables > Edit... > append ;<path-to-your-java-bin-dir> . At least it is on Windows Vista. Should be almost the same on 7, but not sure. --Nat Pavasant 15:14, 8 August 2010 (UTC)

That fixed it! Thank you very much. I can't wait to start Robocoding again:-)--CrazyBassoonist 15:22, 8 August 2010 (UTC)

There are no threads on this page yet.