Talk:Robocode/Older Developers Guide for building Robocode

From Robowiki
Jump to navigation Jump to search

Building Robocode

I'm using Eclipse(Version: 3.2.2), I've downloaded the robocode's source in .zip format, then I've imported it as "existing project", but I still got the error: is not on the classpath. Perhaps JAVA_HOME does not point to the JDK. It is currently set to "/usr/lib/jvm/java-6-sun-" I've understand that JAVA_HOME have to be changed to my sdk, but how? Modify the OS classpath hasn't work, modyfy project standard jre hasn't work, other idea? my OS is ubuntu hardy X64

  • On my Ubuntu 8.10 x64 I use the java-6-openjdk, which I download and installed from Sun's JDK pages. I set up the JAVA_HOME and PATH in my .bashrc file, i.e. for my user account. I have added these lines in .bashrc:
# exports for Java
export JAVA_HOME=/usr/lib/jvm/java-6-openjdk/
export PATH=$JAVA_HOME/bin:$PATH

I hope this helps you! --Fnl 22:53, 25 February 2009 (UTC)


Thread titleRepliesLast modified
Building Robocode (Compilation)018:28, 27 December 2015
Building Robocode023:18, 5 February 2014

Building Robocode (Compilation)

Just a small update when trying to compile Robocode for the first time using Eclipse: You might have a compilation error saying that such a folder does not exist. To solve this make sure to add "basedir" to Window --> Preferences --> Ant --> Runtime --> Properties and its value should be the path to your robocode workspace.

I had this issue lately and that was how I solved it :)

Ayoubm (talk)18:28, 27 December 2015

Building Robocode

Please be aware that you need to use Maven 2, not 3 to build. Just had to debug maven to find out why it would not run. Also mvn.cmd will mess with you trying to execute mvn from your path. i would recommend renaming mvn.cmd to mvn_.cmd I have tried migrating the poms to 3, but not had much luck, backed out and switched back to maven 2.

Dragonbyte (talk)23:18, 5 February 2014