Archived talk:Kenran

From RoboWiki
Jump to: navigation, search

I took the freedom of erasing all my old and deprecated stuff which just cluttered this page :) Please inform me if this is "bad" behaviour here, then we can restore it!

I also have some questions, and wonder if there is a good way to talk to more experienced Robocoders, like some IRC channel or similar, or a good place to post these questions?

While I'm at it, I wonder how to get LiteRumble running. I downloaded a "superpack" from the talk page of LiteRumble, but it was for for some 1.7.x version, and someone mentioned to update the client to the newest version. So could I just create a new folder for the most recent robocode, copy all the bots from the superpack there and change the roborumble settings? What's the most elegant way? :) And do the bots update automatically? I don't want to be just trying it out, since I fear I could destroy something by doing this.. --Kenran 19:38, 16 April 2013 (UTC)

No problem just clearing your talk page, it's up to you. You could also archive it, eg: Archived talk:User:Voidious 20110909. I think just posting to your talk page, or the talk page of whatever topic, is probably the best place to ask questions, then everyone can see it and respond. About chatting, we don't have an IRC channel, and it might be tough to sync up since a lot of folks are geographically spread out here. I'm my handle on AIM or at gmail for GTalk if you want to try to catch me on IM - a few of us chat that way sometimes.
In 1.8.1.0, Fnl updated the RoboRumble configs to point to LiteRumble. So yeah, I think you can just make a fresh install of 1.8.1.0, edit your name in roborumble/roborumble.txt, and start up roborumble.sh (or melee/team/twinduel .txt and .sh). It checks the participants list on the wiki and downloads missing bots, but copying the set from the superpack will save you some time. I also like to set ITERATE=NOT in the .txt file and have the .sh file setup to loop, and that's how they are in the superpack, but I'm not sure you really need to futz with that. You can also set UPLOAD=NOT in roborumble.txt to run without uploading, if you want to be extra paranoid about messing things up on your first try. :-) Let us know if you hit any snags. --Voidious 00:11, 17 April 2013 (UTC)
As a quick note, as far as downloading the complete set of bots, what's more up to date than the superpack is http://robocode-archive.strangeautomata.com/participants-latest.zip, which is automatically updated hourly to contain the complete set of all bots in the rumble. --Rednaxela 05:44, 17 April 2013 (UTC)
Thank you both, it worked out perfectly! Now I can go on about recreating my last bot... lost all my code there and I could beat myself for not including it in the package in the first place... ;) Maybe once I encounter some problems, I will structure this page to make an own category for questions and, hopefully, answers :) --Kenran 08:25, 17 April 2013 (UTC)

Another short question: on the top right of the robowiki, there's always 'new messages (1)', but when I click on it, it says there are none. Is this a bug? And how could I fix this, by clearing browser cache or stuff like that?

That happens to me a lot too. I've just learned to ignore it. I assume the problem is on the wiki's end, so I doubt clearing your browser cache would do much good, but go ahead and try it if you want to.
Sheldor 20:46, 18 April 2013 (UTC)
Maybe we can just get rid of that... Mine says 2416 and crashes with out-of-memory when I try to click it. :-P --Voidious 21:15, 18 April 2013 (UTC)

Contents

Thread titleRepliesLast modified
What does this LiteRumble server message mean?219:48, 17 April 2013

What does this LiteRumble server message mean?

I just uploaded a very first version of my bot to the rumble, and when running battles now, I sometimes seem to get the message "Ignoring: some bot, kenran.InfiniteObscurity 0.8,SERVER". What does this mean? Did someone else maybe just queue the results of this pairing, or is there anything wrong with my bot perhaps? I know it's a total slow-bot right now, I have to work on efficiency with the List I'm running through every tick.

Kenran11:27, 17 April 2013

That just means that your client got duplicate requests for running that battle, so it is ignoring the one. Don't worry about it.

Skilgannon19:01, 17 April 2013
 

Thanks!

Kenran19:48, 17 April 2013
 
Personal tools